Steps:
This steps have been done on AIX 6.1. TL6
Map the hdiskY or lun to both the system
On system1:-
lspv
cfgmgr ** to get new hdiskY/lun
Now Extendvg
extendvg vgname hdisky/lun
-----------------------------------------------------------------------------------------------
******if you are unable to extendvg due to Max pp limitation then change the Vg properties.
chvg -t 2|3|4 (etc) vgname
-----------------------------------------------------------------------------------------------
extendvg vgname hdiskY
mirrorvg vgname hdiskY
lsvg -l vgname * check all fs are syncd and consistent, else wait to get it consistent.
Now split the VG
splitvg -y new_vgname -c 2 -i old_vgname
( -i is used so that hdiskY cant join the vg again and lv/fs remain consistent, else if you need the hdisk to rejoin the vg then dont use -i , -c 2 is to separate the second copy of lv i.e hdiskY)
varyoffvg new_vgname
exportvg new_vgname
rmdev -Rdl hdiskY
=======================
ON System 2:
Then map same hdiskY/lun to different system if you have not done earlier
lpsv
cfgmgr
lspv
importvg -y vgname( name you like to put) hdiskY
cp -p /etc/filesystems /etc/filesystems_copy
edit /etc/filesystems remove unwanted prefix like /fs/fs etc
mount all
check VG is doenst have any stale Lv.
Check files and application.
Remove mapping of hdisky/lun from system1.
Map the hdiskY or lun to both the system
On system1:-
lspv
cfgmgr ** to get new hdiskY/lun
Now Extendvg
extendvg vgname hdisky/lun
-----------------------------------------------------------------------------------------------
******if you are unable to extendvg due to Max pp limitation then change the Vg properties.
chvg -t 2|3|4 (etc) vgname
-----------------------------------------------------------------------------------------------
extendvg vgname hdiskY
mirrorvg vgname hdiskY
lsvg -l vgname * check all fs are syncd and consistent, else wait to get it consistent.
Now split the VG
splitvg -y new_vgname -c 2 -i old_vgname
( -i is used so that hdiskY cant join the vg again and lv/fs remain consistent, else if you need the hdisk to rejoin the vg then dont use -i , -c 2 is to separate the second copy of lv i.e hdiskY)
varyoffvg new_vgname
exportvg new_vgname
rmdev -Rdl hdiskY
=======================
ON System 2:
Then map same hdiskY/lun to different system if you have not done earlier
lpsv
cfgmgr
lspv
importvg -y vgname( name you like to put) hdiskY
cp -p /etc/filesystems /etc/filesystems_copy
edit /etc/filesystems remove unwanted prefix like /fs/fs etc
mount all
check VG is doenst have any stale Lv.
Check files and application.
Remove mapping of hdisky/lun from system1.